Medien + Technik-Blog

Praxis- und Testberichte | Tipps & Tricks

In meinem Blogeintrag vom 6.6.2012 schrieb ich über die (Un)Möglichkeiten eine SSD im Apple Mac Pro zu verbauen.
In einem Kommentar dazu ist eine Behauptung eines Händlers aufgetaucht, wonach ein Controller im Einbaurahmen die Ursache für eine KernelPanic des MacPro wäre.
Derart falsche “Erklärungen” tauchen auch des öfteren in Foren auf – ich möchte dies hiermit ein für alle Mal richtigstellen:

Der Kensington Einbaurahmen hat KEINEN Controller eingebaut!

…das kann ja jeder behaupten?
Klar, deswegen hab ich mir die Mühe gemacht und den MacPro runtergefahren, den Rahmen zerlegt, und die Platine fotografiert ;)

Wie man auf dem Foto eindeutig sehen kann, ist die eingebaute Platine eine reine 1:1 Verbindung der Ein-und Ausgänge.
Die Platine ersetzt in diesem Fall nur Kabel und Drähte!
Es sind keine elektronischen Bauteile und somit auch kein Controller vorhanden.

Bei Amazon gab es vor Kurzem ein gutes Angebot von einem Samsung SSD 830 (MZ-7PC256B) (=Solid State Drive – übersetzt bedeutet das ein Laufwerk mit festem (Speicher-)Zustand equivalent mit einer Festplatte, nur ohne mechanische Teile weil es auf Halbleitertechnik basiert und deswegen auch um ein vielfaches schneller ist – mehr dazu beim SpeedTest)
Wer allerdings auf den Vorschlag von Amazon eingeht und Einbau-Adapter mitbestellt, wird scheitern – vorausgesetzt er will den Festplattenschlitten des MacPro für das SSD nutzen.
In meinem Fall waren diese Blechwinkel umsonst:

Schraubt man diese auf das SSD, würde sie in einem 5,25″ Einbauschacht mittig platziert werden.
Das ist bei einer losen Verkabelung kein Problem, aber im MacPro hängt so gut wie kein Kabel herum.
Die SATA Anschlüsse sind fix auf dem Mainboard befestigt und eine Positionsänderung nicht möglich.
Der MacPro hat platzsparende Festplatteneinschübe, bei denen die Festplatte von oben fixiert wird.
Diese Adapterbleche helfen also nicht weiter.

Im Netz habe ich schnell folgende Einbaulösung gefunden:

Scherz beiseite – nach etwas längerem Stöbern im Netz habe ich folgende Lösungen gefunden:
IcyDock (Kunststoff)
IcyDock (Aluminium)
Kingston (Kunststoff)
Schlussendlich habe ich den günstigsten Einbaurahmen von Kingston gekauft – der 2.5″ to 3.5″ SATA Drive Carrier ist um 5€ günstiger als das IcyDock MB882SP-1S-1B und beim Computerhändler in der näheren Umgebung zu haben.

Das Teil ist aus schwarzem Kunststoff mit eingepressten Messing-Gewindebuchsen.

Für die Montage des SSD braucht man kein Werkzeug. Einfach das SSD hineinlegen und den Deckel schließen. Alles andere erledigt die Metallblech- Mechanik im Inneren des Carriers.

Der Carrier muss natürlich per Kreuz-Schraubendreher an die Apple-Einschub-Schlitten des MacPro montiert werden – aber das war’s dann auch schon an Werkzeugeinsatz.

Edit:
Um ein zweites SSD einzubauen wurde diesmal (auch wieder aus Kostengründen) das IcyDock bestellt.
Von Außen sieht es baugleich zum Kingston aus, aber das Innenleben ist viel billiger gestaltet:

Um eine Festplatte im Schlitten des MacPro montieren zu können, sind Gewindeschrauben angebracht.
Damit diese Schrauben auch im Kunststoff-Dock halten, sind Gewindebuchsen aus Messing eingepresst.
Leider wurde auch hier geschlampt, denn die Buchse löst sich einfach vom Dock:

Ich rate eindeutig zum hochwertigeren Kingston-Teil!
End of edit

Die Systemplatte kann man nun (z.B. per CCC) auf das SSD klonen und sich schon beim nächsten hochfahren über die Geschwindigkeit freuen.
Im Gegensatz zu den Festplatten, die teilweise ein nahendes Ende akustisch ankündigen, funktionieren SSDs einfach plötzlich nicht mehr.
Um die Datensicherheit zu erhöhen sollte man deswegen gleich eine TimeMachine-Sicherung erstellen und die automatische Sicherung auf ein anderes Laufwerk (z.B. eine Festplatte) aktivieren.
In meinem MacPro kann das SSD folgende Geschwindigkeiten erreichen:

Im Gegensatz dazu eine Festplatte mit 7200U/min:

Insgesamt hat der Umbau 198€ und 5min. Zeit gekostet – und er ist es wert :)

Der Mediaplayer auvisio MVP-520.3D wurde dankenswerterweise zur Verfügung gestellt von einer Firma für postproduction. Er durchlief unseren Test mit überraschend guter Leistung:
Der Lieferumfang beinhaltet:

Lieferumfang

  • Player
  • Fernbedienung
  • hochwertig aussehendes HDMI-Kabel mit Goldkontakten
  • AV-Kabel mit 3 x cinch Stecker auf cinch Stecker: Video (gelb), Audio L (weiß), Audio R (rot)
  • 5V Netzteil
  • miniUSB-Kabel

Das Einrichten des Gerätes ist ein Kinderspiel – Netzteil und HDMI-Kabel anstecken, entweder am Power-Button am Gerät oder auf der Fernbedinung einschalten, fertig.

Der Player hat zusätzlich einen FBAS- (engl.: CVBS) sowie einen VGA-Ausgang- deren Funktion kann man in den Einstellungen sowie auf der Fernbedienung aktivieren.
Hier kann immer nur 1 Ausgang betrieben werden.

Ca. 9-10sek. nach dem Einschalten ist der Player hochgefahren. Das Menü sieht dank Apple-like Icons sogar seriös aus:

Per Druck auf die “Setup”-Taste auf der Fernbedienung oder Navigation zu den “Einstellunge” im Menü, kann man folgendes einstellen:

Steckt man nun eine SD-Karte oder einen USB-Stick an, kann man per “Files”-Taste darauf zugreifen. Auch ein Navigieren über z.B. “Filme” -> USB -> USB kann man dann den Inhalt des Speichermediums betrachten.
Hier werden übrigens auch die normalerweise versteckten Dateien – wie sie MAC OSX zur Sicherung anlegt – angezeigt.

 


Es werden folgende Codecs werden unterstützt (Scan der Bedienungsanleitung):

Hier gilt es anzumerken, dass sehr wohl ein 1920 x 1080p H264 Video einwandfrei abgespielt wurde – auch wenn nicht im Handbuch angegeben!
Nachtrag: Auch ein H264 Codiertes Video in einem mp4-Container (wie für AppleTV) wird problemlos und ruckelfrei abgespielt.

Die Fernbedienung ist die einzige Möglichkeit den Player zu bedienen (ausser Power on /off am Gerät).
Sie wird mit einer 3V Lithium-Zelle (CR2025) betrieben welche sich im Lieferumfang befindet.

Ein Minus gibt es hier gleich bei der Usability: Man erhält kein Feedback ob der Tastendruck der Fernbedienung empfangen wird oder nicht, da nicht immer Geräusch (klick) abgespielt wird und keine blinkende “IR-Receiver-LED” einen Empfang signalisiert. Verlässlich empfangen werden die Befehle übrigens in der Vertikalen fast 180° und in der Horizontalen auf ca. 145° .

Die versprochene Foto-Diashow mit Musikuntermalung konnte noch nicht gefunden werden.
Die Fotos werden ausserdem 1:1 angezeigt oder verkleinert. Vergrößern kann man das Bild per “zoom” Taste – hier hat man 3 Vergrößerungsstufen zur Verfügung. Die Abfolge ist: normal, 1x, 2x, 3x, 2x, 1x, normal zoom.

Bei den Videos übernimmt der “Scale” – Button eine ähnliche Funktion.
Man kann wählen zwischen:

  • normal
  • 4:3
  • 16:9
  • Anpassen
  • Vollbild
  • Vollbild (?)

Weitere Einstellungen kann man per Taste “OSD” (OnScreenDisplay) übernehmen:

OnScreenDisplay

Der Modus beschreibt das Abspielverhalten der Filme:

  • alle wiederholen
  • Reihenfolge
  • Zufall
  • nur einmal
  • eins wiederholen

Als Untertitel-Schriftsatz kann man wählen:

  • UTF8, UTF16BE, UTF16LE
  • BIG5
  • GBK
  • SJIS
  • EUC_JP, EUC_KR
  • KIO8_R
  • ISO_8859_1 bis ISO_8859_13 und ISO_8859_16
  • CP847, CP1250, CP1251, CP1255, CP1258
  • GB2312

Ich hatte neulich die Möglichkeit eine Matrox MXO2 LE mit MAX-Technologie zu testen.

MATROX MXO2 LE

MATROX MXO2 LE

Im Lieferumfang befinden sich:

  • Netzteil mit UK- und EURO – Schukosteckeranschlusskabeln
  • PCIe – Karte oder Expresscard34
  • Breakout-Box
  • Verbindungskabel
  • 3 Stk. BNC -> Cinch – Adapter

Nachdem mein Computer seinen Platz unter dem Schreibtisch hat, und die Box platz finden soll ist das mitgelieferte 1m lange Hostkabel fast zu kurz.
Es gibt jedoch ein 3m- PCIe Hostkabel als Zubehör um ca.85€. Auch eine zusätzliche Controller-Karte – z.B. für den ExpressCard34- Slot eines MacBook Pro ist um ca. 99€ erhältlich.

Der Anfangstest galt der Monitorvorschau und -kalibrierung:

Der 24″ LCD-Monitor Viewsonic vx2435wm wurde anfangs per HDMI-Kabel an die MXO2 angeschlossen.
Im FinalCutPro musste man das Vorschaugerät und auswählen.
Dann muss das richtige Testbild  im FinalCut geladen und der HDMI-Output des MXO2 mit dem Kalibrations-Tool eingestellt werden.
Wie das genau funktioniert sieht man in diesem Video.

Die Farben stimmten nun, doch das Testbild – ein roter Kreis – war verzerrt.

Matrox MXo2 LE 16:9

16:9 - Einstellung des Monitors

Wenn man auf dem Monitor das Bildformat auf 1:1 stellt, erscheint der Kreis zwar rund, aber von den 24″ Bilddiagonale des TFTs werden nur 21″ für die Darstellung genutzt.

Matrox MXO2 LE - 1:1 Mapping

1:1 Mapping - nur 21" in Verwendung

Falls man also die Farben per HDMI als passend empfindet heißt das noch lange nicht, dass die Farben richtig zum Recorder geschickt werden der evtl. per Component angeschlossen ist.
Der Monitor zeigte per HDMI folgendes Bild an:

Matrox MXO2 LE HDMI

richtige Farben per HDMI

Per Component jedoch sah das gleiche Bild so aus:

Matrox MXO2 LE

falsche Farben per Component

Adobe After Effects kommt mit der MXO2 LE auch super zurecht – was man von Apple Shake nicht behaupten kann.

Mit Photoshop kann die MXO2 auch nicht verwendet werden denn auch hier wird das Gerät einfach nicht erkannt.

Der nächste Test galt dem Aufnehmen und Kodieren:

Die Canon XH-A1 wurde per Component an die Box angeschlossen wobei sich die mitgelieferten BNC-auf-Cinch-Adapter als sehr nützlich erweisen.
Die Aufnahme erfolgte in “Apple ProRes 422 HQ” – die Einstellungen in den FinalCut Voreinstellungen waren im Nu erledigt.

Ein Problem tritt allerdings auf, wenn man eine Multiformat-Timeline verwendet. Dann wird beim Abspielen gerade ein Frame angezeigt, dann:
Standbild am Vorschaumonitor über die MXO2 – während der MacPro ganz normal weiterspielte. In diesem Fall war es ein 1080i-Material in einer 720p – Sequenz.

Beim Encoding mit den MAX-Presets fällt zwar die Geschwindigkeit positiv auf, jedoch ist die Kehrseite der Medaille ein verdunkeltes Kodierungsergebnis
was die Vorschaumonitorkalibrierung für Internetvideos im Prinzip auch unbrauchbar macht:

MXO2 Standard Kodierung

Standard Compressor H264 Kodierung

MXO2 MAX

MXO2 MAX H264 Kodierung

Da die MAX-Technik ist ausschließlich für die H264-Kodierung optimiert ist, wird zwar das Erstellen von BluRays beschleunigt, jedoch bringt es beim MPEG2- komprimieren für DVDs keinen Vorteil.
Während des Encodings eines 918MB ProRes422 (HQ) – Files auf 26MB H264 wurde die MXO2 höchstens handwarm.

Die LiveRecording-Software BoinxTV verspricht gute Zusammenarbeit mit der MXO2.
Zu viel versprochen, denn sobald zu einem Layer mit MXO2-Quelle z.B. eine FireWire- Quelle geschalten wird, fängt die MXO2-Quelle zu ruckeln an (und das in SD-Auflösung!) und ist also hier auch unbrauchbar.

Fazit:
Für mein Setup erschließt sich der Sinn dieses Gerätes nicht ganz.
Das viel beworbene Mega-Feature – die Verwendung von HDMI-Monitoren und sie wie Broadcast- Monitore zu kalibrieren hat wenig Sinn, wenn die Ausgabe auf den anderen Outputs bzw. sogar bei der MAX-Kodierung falsche Farben aufweist. Da helfen auch die professionellen BNC-Anschlüsse mit SDI, Genlock und Component nicht drüber hinweg.
Die FinalCut-Unterstützung wird auch groß beworben, jedoch ist in einer Multiformat-Timeline davon leider nichts zu spüren.
Hier muss man sich anscheinend bei anderen Firmen wie z.B. Blackmagic Design umsehen.

Danke an die Firma websys-media aus steyr, die mir die MXO2 borgte und diesen Test ermöglichte.

Meine XH-A1 hatte – wie hier schon erwähnt einen Transportschaden. Da ich sie aber in Verwendung hatte, wurde sie erst am 6.4.2009 von mir zur Werkstatt gebracht und bereits am nächsten Tag begutachtet.

Nach etlichen Anrufen nach Deutschland war geklärt, dass Kosten der Reparatur vom Verkäufer übernommen werden, wenn diese 100€ nicht übersteigen werden.
Am 4.5.09 war die Kamera dann repariert und nun wartete ich darauf, dass der Verkäufer die Rechnung bezahlt, damit ich die Kamera abholen kann.
Das artete leider zu einem Problem aus, denn A.Medientechnik aus Krefeld “macht nicht mehr viel mit Mails” – und das bekommt man von einem deutschen Online-Store zu hören…
Nun galt es die Reparaturfirma zu bitten die Rechnung zu faxen – was sie auch tat. Nachdem zwei Wochen vergingen und noch immer keine Meldung kam, dass die Rep. bezahlt wurde, mailte ich A.M. – um als Antwort zu bekommen, dass die Geschäfte von nun an aus den USA abgewickelt werden und ich dort anrufen sollte. Ich rief sofort bei der Firma an. Die Sekretärin sagte mir, dass Herr W. erst am 15. wieder im Land sein werde und schickte ein Fax an Fa. Schuhmann, dass das Geld überwiesen werde.
Natürlich rief ich am 15. gleich wieder an und er meinte er habe die Rechnung schon am Schreibtisch liegen und werde sich in den nächsten Tagen darum kümmern.
2 Wochen lang geschah nichts. dann rief ich wieder an. “Ja wissen Sie, da muss unsere UID-Nummer draufstehen” – also bat ich Fa. Schuhmann die Rechnung zu überarbeiten, mir zu mailen und der Fa. A.M. zu faxen.
Nachdem ich diese Fa. einige Tage nicht erreicht habe – es ging keiner ans Telefon – war es am 10.6. dann doch so weit:
“Das Fax ist leider verschwunden – können Sie es noch einmal Faxen?” Nachdem ich ihm klar machte, dass nicht mehr hin und her gefaxt wird, und er sogar ein MAIL mit der Rechnung erhalten hat, meinte er findet es nicht. Ich sagte ihm wonach er suchen sollte und an welchem Tag es von wem geschickt wurde – et voilá – er hatte es gefunden.
Herr W. von A.M. meinte nicht überweisen zu können weil keine IBAN Bic/Swift – Bankdaten angegeben waren. Also wieder eine Bitte an Fa. Schuhmann diese Daten zu schicken, denn auf der Homepage waren sie nicht zu finden.
Nun sollte alles geklärt sein – komisch, dass nach 2 Wochen immer noch kein Geld bei Fa. Schuhmann eingetroffen war…
Nach einem weiteren Anruf warum die Reparatur noch nicht bezahlt wurde, meinte er er mache das gleich.
Ich schickte der Firma erneut die Rechnung, und manövrierte Herrn W. wieder durch seine Emails.
Die Kosten der Reparatur wurden endlich übernommen – am 09.07.09 – und ich halte meine Kamera wieder in den Händen. Ausgetauscht wurde folgender Bauteil:
und eine Schraube wurde ersetzt. Die Rep. kostete 98€ – Dank der Bürokratie von A.M. musste ich auf die Bezahlung 3 Monate warten.
Nachtrag, 23.07.09:
Heute ist die Telefonrechnung gekommen: Das Telefonieren mit A.M. hat mich 25€ gekostet (Österreich -> Deutschland).
Auch wenn die Preise der Produkte teilweise verlockend sind – bei A.M. kaufe ich nicht mehr ein!
Nachtrag, 2012:
Mittlerweile häufen sich Berichte, in denen über kratzende Objektivringe, fehlende Zubehörteile  (Akkus, Objektivdeckel, Kameragurte),  und vor allem falsche ebay-Fotos besagter Firma geklagt wird.
Rücksendungen werden tagelang nicht abgeholt, und erst nach zig Mails wird das Geld nach einem Monat erst zurück überwiesen.
Darüber hinaus kommen FAX-Sendungen nicht an, Auskunft kann nicht gegeben werden und der versprochene Rückruf erfolgt so gut wie nie.